Affected by Cloudflare Outage

Incident Report for Plan A

Resolved

Cloudflare has resolved the issue. The app should return to normal shortly. You may need to clear your browser cache.
Posted Nov 18, 2025 - 14:49 UTC

Update

We are continuing to monitor Cloudflare's updates
Posted Nov 18, 2025 - 12:15 UTC

Identified

Users of our app may see 500 pages and receive other errors. For status updates, see https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 12:12 UTC
This incident affected: App.