Server outage
Incident Report for Plan A
Resolved
This incident has been resolved.
Posted Jun 14, 2023 - 14:01 UTC
Investigating
We are currently investigating this issue.
Posted Jun 14, 2023 - 13:49 UTC
This incident affected: App.